Skip to content
Grav 2.1 is out: every page speaks Markdown. Read the announcement →

Error: https:// wrapper disabled if js_pipeline is true

Started by Muut Archive 11 years ago · 5 replies · 433 views
11 years ago

If I am turning js_pipeline on, it works fine on localhost but not on my hosting, there I get the following error message:

"An exception has been thrown during the rendering of a template ("file_get_contents(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0") in "partials/base.html.twig" at line 63."

Line: 63: {{ assets.js() }}

Is this a bug, or do I need any further configuration (because js_pipeline need https)?

11 years ago

Thanks! My question is wether js_pipline does need https?

11 years ago

Are you trying to load a particular JS file via https?

11 years ago

Oh well, right! There is one called via https (webfontloader) and the rest via theme-directory.

11 years ago

Ok, now I have embedded this particular js directly to the theme, now everything is fine! Good to know how js_pipeline is working. Thanks!

Suggested topics

Topic Participants Replies Views Activity
Archive · by Deleted User, 9 years ago
0 2280 9 years ago
Archive · by Muut Archive, 9 years ago
2 1496 9 years ago
Archive · by Muut Archive, 9 years ago
2 4745 9 years ago
Archive · by Muut Archive, 9 years ago
1 3560 9 years ago
Archive · by Muut Archive, 9 years ago
3 1621 9 years ago