Skip to content
Grav 2.1 is out: every page speaks Markdown. Read the announcement →

I can't check for updates due to peer certificate authentication error

Solved by Karmalakas View solution

Started by Peter Simkovic 5 years ago · 6 replies · 2634 views
5 years ago

When I log in to my website Administration Panel, I get this error message:

Peer certificate cannot be authenticated with given CA certificates for "https://getgrav.org/blog.atom".

with invalid AJAX response therefore I cannot check for updates both Plug-ins and system.

5 years ago

Same here. Didn't even update Grav for a while now. It just started happening

5 years ago Solution

OK, so I talked to my sys admin and he confirmed that most have expired root certificates and he advised me to add peer SSL verification to false where request is initiated. So I remembered I saw something about that, but then found this old topic. Then I found this setting is in /config/system.yaml, so in Admin went to Configuration > System > Advanced and have set Remote Verify Peer (SSL) to No

Now it works as expected (Grav news, plugins updates)
I suppose until every website fixes root certificates, will have to live with this option off

👍 5
2 replies
5 years ago

Thank you for your advice, it helps me to solve my problem.

Suggested topics

Topic Participants Replies Views Activity
Support · by complanar, 6 days ago
6 138 13 hours ago
Support · by Rick Beebe, 6 days ago
2 100 2 days ago
Support · by blu3prince, 3 days ago
0 50 3 days ago
Support · by alex, 4 days ago
2 92 3 days ago
Support · by Marcel, 2 weeks ago
1 142 4 days ago