Skip to content
Grav 2.1 is out: every page speaks Markdown. Read the announcement →

New theme - getting 400 error 'blog.html.twig' is undefined

solved

Solved by Glenn View solution

Started by Glenn 8 years ago · 1 replies · 1309 views
8 years ago

I've read the previous threads that seemed relevant - tried a few changes but none did anything.

So I switch from Quark to Masonry and get this error. It's not a particularly helpful error. The only thing I can see is that the Masonry theme does not have a blog.html.twig template. It does, however, have a post.html.twig template. Should I rename it? Should I change something in my post files? Should I rename my post files?

Really lost here...

8 years ago Solution

Well now - never mind!

Went back to Pages > 02.Blog > Advanced - changed the Page template to post, then page - both at least got a page with various things on them instead of the error. Then I changed it back to default and behold, we have blog posts! Guess something was cached? No idea...

Suggested topics

Topic Participants Replies Views Activity
Support · by complanar, 6 days ago
6 139 15 hours ago
Support · by Rick Beebe, 6 days ago
2 100 2 days ago
Support · by blu3prince, 3 days ago
0 51 3 days ago
Support · by alex, 4 days ago
2 92 3 days ago
Support · by Marcel, 2 weeks ago
1 143 4 days ago